Official StoreTekan tombol di atas untuk membeli semua alat dan bahan eksperimen di web ini

Troubleshoot Koneksi Modem Dengan Hyperterminal

Hyperterminal merupakan software bawaan Windows XP yang fungsinya melakukan komunikasi dengan device lain melalui protocol komunikasi serial ataupun TCP/IP. Software ini sangat bermanfaat sekali untuk melakukan troubleshoot koneksi dengan modem, karena dapat melewatkan perintah AT command ke modem. Jika Anda merasa kesulitan untuk mencoba program-program Delphi yang berhubungan dengan modem yang ada di blog saya ini, ada baiknya Anda menguji modem dan AT command melalui software hyperterminal terlebih dahulu. Jika modem Anda support AT command, dan sudah bisa berkomunikasi dengan hyperterminal, saya yakin Anda tidak akan kesulitan bermigrasi ke ranah programming (Delphi atau bahasa pemrograman lain).

Hyperterminal ini dapat Anda temukan melalui menu Start | Accessories | Communications | HyperTerminal.

Setelah itu akan muncul window sebagai berikut. Tulis nama ‘New Connection’ dengan ‘tes modem’

Berikutnya Anda akan diminta untuk memasukkan tipe koneksi. Pilih option ‘Connect using:’ dengan COM Port dimana modem Anda menciptakan virtual serial port. Sebagai contoh modem saya berada di COM42.

Catatan : Untuk melihat virtual serial port yang diciptakan driver modem, Anda perlu menuju Device Manager | Port (COM & LPT)

Langkah berikutnya adalah melakukan setting parameter koneksi serial. Secara umum semua tipe modem mendukung baudrate 9600. Oleh karena itu tekan saja tombol ‘Restore default’

Catatan : Jika Anda menggunakan modem wavecom, settinglah baudrate di 115200, karena factory setting modem ini ada di angka tersebut.

Setelah selesai setting parameter, maka window hyperteminal akan muncul. Ketikkan ‘at’ (tanpa tanda petik) dan tekan tombol enter

Jika hyperterminal sudah terhubung dengan modem, maka dalam window hyperterminal akan mendapat ‘jawaban’ dari modem dengan tulisan ‘OK’.  Jika tulisan ‘at’ tidak muncul di window hyperterminal, tidak usah khawatir, karena mungkin secara default memang tidak diaktifkan fitur echo command-nya. Untuk mengaktifkan fitur echo (pengulangan/penulisan command) ketikkan ‘ate’ tekan enter. Setalah itu ketik ‘at’ lagi untuk meyakinkan proses pengaktifan echo telah berhasil. Seharusnya tulisan ‘at’ sekarang sudah muncul.

Untuk lebih meyakinkan lagi bahwa hyperterminal sudah bisa melakukan komunikasi dengan modem, ada baiknya Anda mengetikkan command sebagai berikut :

At+cgmi (menanyakan manufacturer modem)

At+cgsn (menanyakan serial number modem)

Perhatikan ‘jawaban’ dari modem, apakah sudah sesuai dengan data modem Anda, jika sesuai berarti modem Anda  support AT command dan siap diprogram dengan Delphi (atau bahasa pemorograman yang lain). Selamat mencoba

Incoming search terms:

reset modem wavecom menggunakan at command pada hyperterminal, cara setting hyperterminal, cara seting usb modem menggunakan hyer terminal, penyebab tidak bisa mengetik di hyperterminal, modem wavecom tidak konek, alasan mengapa tidak muncul tulisan di hyperterminal setelah connect, cara reset modem melalui hyperterminal, cara konfig modem dengan hyper terminal, cara konek arduino ke modem, at command hyperterminal tidak muncul tulisan
0 0 vote
Article Rating
Subscribe
Notify of
guest
39 Comments
Oldest
Newest Most Voted
Inline Feedbacks
View all comments
budi

manthab

bluvent

koq di text editornya gamau diketik ya ?

zizie

mas mau tanya, kalo modem udah kita konekin dan udah bisa diketik tapi gak bisa di enter, kira-kira pybab nya apa ya?

sena

mas,, kalo pas kirim sms,, kok muncul error,
terus saya cek erornya ,, error 513,,
padahal formatnya udah bener

AT

OK

AT+CMGF=1
AT+CMGS=”087777xxx”
pesan ——> ctrl+z

muncul tulisan error 513,,
gimana ngatasinnya ya? padahal udah coba ganti kartu beberapa kali,,
signal strengthnya high,, mohon pencerahannya mas

herdianna

mas mau tanya,,
udah di setting sesuai kok waktu di ketik AT gak muncul OK.
kalo kayak gitu kenapa ya???
mohon bantuannya..

Tiyas

mas ini udah konek, tp kok di text editor gak bisa diketik ? padahal echonya udah diaktifin jg tp tetep nggak mau diketik dan nggak muncul pesan OK

Tiyas

portnya sudah bener mas, sudah tak exit jg tp tetep nggak bisa diketik di teks editornya, apa modemnya yang bermasalah ya ? saya pakai modem HUAWAI E173 ? Mohon pencerahannya ya mas, trims…

Tiyas

GSM mas

imam

Tanya mas.. sy sudah buat aplikasi sms dengan delphi + tcomport.. kalo pake modem internet biasa (Huawei E160), gak ada masalah, pas ganti modem wavecom, PORT selalu gak kedetect oleh aplikasi.. apa ada settingan khusus untuk modem wavecom mengenai PORTnya?

topa

gan mau nanya nih..kenapa ya gan ketika setelah saya ikutn tutorial di atas ketika hyperterminal saya buka, setelah itu saya ketik huruf dan angka dari keyboard yang muncul semua adalah karakter bukan huruf atau angka? terimakasih sebelumnya gan…

widya

mas, saya udah mengetikan ‘ATE1’, tetap tidak muncul OK mas, itu apa yang salah ya mas?

widya

driver nya sudah ok dan port nya pun uga sudah ok. saat ya koneksikan di hyperterminal, tulisan di pojok bawak sudah connected. tapi saat saya tulis ATE1 itu ttp tidak bisa mas ;(

widya

sebelumnya saya sudah pernah menggunakan modem nya mas, dan itu langsung bisa di ketik. software bawaan moden nya itu yang mana ya ams?

zaka

malam mas… saya ingin bertanya ni status saya masi disco, sudah saya cek di bagian device manager klo saya menggunakan COM 4 dengan bitrate 9600.. tapi coba masih gagal bisa membatu saya kasih solusi. ty

zaka

malam mas… saya ingin bertanya ni status saya masi disco, sudah saya cek di bagian device manager klo saya menggunakan COM 4 dengan bitrate 9600.. tapi coba masih gagal bisa membatu saya kasih solusi. ty

saya menggunakan MODUL GSM SIM900 A

zaka

ane pake TTL to USB 232, berarti baudrate yg di device manager (9600) di ubah menjadi 115200?… ane udah bisa ngetik perinta AT tapi no respond, ane juga udah baca di posting antum yang solusi hyperterminal not respon, tetapi sama saja … ada solusi lain gan? terima kasih 🙂

zaka

punya saya modul 900A v.4 kit wireless gan… sudah saya periksa tidak ada push buttonnya… tapi indikator LEDnya ngeblink ko.

nurhari

mas kok pesan yang dikirim dari modem ke hp kok gak nampil isi pesannya ya? modem yang saya gunakan wavecom

elsa

mau nanya, ini com nya ud bener, di hyperterminal juga sudah connected, tapi kenapa tetap nggak bisa diketik ya?

saya menggunakan modem gsm M2M

Elsa

Sudah saya ketik ate1 tetap tidak ada jawaban oke dari hyper terminal. Semisal characternya tidak muncul di hyper terminal, bagaimana saya bisa mengganti baudrate nya ya?

39
0
Would love your thoughts, please comment.x
()
x